比特币惊现旧版本漏洞恶意代码或影响网页浏览器BTC价格隐忧?

《比特币惊现旧版本漏洞恶意代码或影响网页浏览器BTC价格隐忧?》

○/文:老李迫击炮,全网同名

周一,Core贡献者和开发人员Andrew Chow披露了一个影响比特币Core早期版本的漏洞,Bitcoin Core是支持比特币的开源软件。该问题已得到修复,其他比特币开发人员都知道该问题,通常会影响Web浏览器,但不会造成任何破坏。

Chow在推文中说,该漏洞存在于Bitcoin Core 0.18及更早版本中,但自0.19版本以来已得到修复。作为参考,比特币当前运行在0.21.0版本上。披露了在Bitcoin Core 0.18及更早版本中可能存在的无法利用的URI参数注入漏洞。自0.19起已修复此问题。

但尽管有警告,周先生说这次袭击不太可能造成损害。他说:“鉴于现代浏览器和Linux桌面环境中存在的缓解措施,我不认为实际上可以利用此漏洞。”Chow补充说:“无论如何利用它,都可能导致RCE(即,在受害者计算机上执行恶意代码)。”

攻击击穿:攻击围绕三个技术方面进行:URI(统一资源标识符的缩写);Qt5是计算机用来标识现实世界和数字对象的标识符,它是创建图形界面的免费程序,最后是在计算机上处理这两种方法的方式。

Chow表示,由于URI注入(漏洞本质的特定术语)是一个已知问题,因此软件开发人员(在本例中为Bitcoin开发人员)知道如何避免此类攻击。

简单来说,这意味着开发人员通常可以轻松地避免URI发送的任何标记信息并防止攻击。但是,问题出在图形软件Qt5上,它无法识别任何错误的URI,并且可能允许不必要的参数(包含数据的数字变量)通过。

从理论上讲,这种漏洞会导致非法代码向计算机发送错误的数据/指令并安装恶意插件。然后,这可能导致用户系统出现故障和/或其他形式的网络犯罪,例如数据盗窃。

但是,幸运的是,大多数Web浏览器已经具有内置系统,可以避免此类攻击并标记任何不必要的参数。这意味着尽管存在此漏洞,但很难利用,Chow指出实际上甚至不可能造成伤害。

同时,该漏洞是Bitcoin Core上第一个此类实例。而且值得再次重复:比特币本身仍然没有受到破坏-该攻击存在于该软件的过去版本中,并且理论上可能会影响用户设备,而不是协议本身。

《比特币惊现旧版本漏洞恶意代码或影响网页浏览器BTC价格隐忧?》

【老李迫击炮-交易思路】昨日XRP大涨大跌,日内ETH出现了下降趋势线的突破领涨,也提振了币市的反弹,近期BTC波动相对温和,简单说下交易思路,小时级别再次出现了下降趋势线的突破,但四小时线预计依然是承压状态,后市关注四小时和日线能否站上35000-35100附近区域,关乎本周前半段走势,突破则会优先偏多运行,上方阻力依次参考38500/40130/4.2w附近;短期承压,可能会优先回调测试短期震荡区间支撑33155/32170附近。至于中后期,鉴于昨日提到的周线和月线收线,后市大概率会再次测试趋势线29600附近,后市下破则有机会看至27777/24300附近。日内我们LTC和BTC现货以及合约多单,都选择了高位35500附近按计划获利减持,接下来等待再次低接,和合约高空机会。以上为“老李迫击炮”原创,转载注明出处

—-

编译者/作者:数字律动

玩币族申明:玩币族作为开放的资讯翻译/分享平台,所提供的所有资讯仅代表作者个人观点,与玩币族平台立场无关,且不构成任何投资理财建议。文章版权归原作者所有。

发表评论

电子邮件地址不会被公开。 必填项已用*标注